Default Avatar

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

estroup

Hello, I am new to this forum. I am having an issue with my TAB 320 heater. I think it is a propane pressure problem. Does the TAB have any kind of propane filter that needs to be serviced? My stove flame seems low pressure and the furnace will not ignite.

About

Username
estroup
Joined
Visits
3
Last Active
Roles
Member
Posts
0

Activity

  • Hello,

    I am new to this forum. I am having an issue with my TAB 320 heater. I think it is a propane pressure problem. Does the TAB have any kind of propane filter that needs to be serviced? My stove flame seems low pressure and the furnace will not ignite.
    January 7
    • ericnliz
      ericnliz
      estroup, Try disconnecting the line to the tank (turn the valve off first), reconnect. Turn the valve for the slowly open, and try it again. Just an FYI, it's helpful if you give the year & model for your trailer when looking for assistance as well. Give it a try, and let us know. Are you sure you have a full tank of propane?
    • estroup
      estroup
      Thank you very much. The Year is a 2013. I think it is a 320. Your suggestion worked. Is this a common problem. My heat has been very reliable until now. We are at high elevation, 10,400 feet but it has worked great at altitude until now. Thanks, Ed
    • ericnliz
      ericnliz
      estroup, Sometimes, when you either change tanks, or turn the propane valve at the tank on too fast, the regulator goes haywire for some, unknown reason. Don't feel badly, or like you're the only one that it has happened to. It's happened to me before & was a real head-scratcher before I decided to start all over again.
      Glad to hear you got it resolved. There is a high altitude regulator fix kit available for the Alde. Call either Marvin, or Elsie for more info. You'll find the number under the nuCamp contacts under Categories. just click on the heading & all the numbers will come up for you.